Em resumo
- CVE-2024-47178 é uma vulnerabilidade MÉDIO (CVSS 5.3) que afeta basic-auth-connect (expressjs), basic-auth-connect.
- Chance de exploração nos próximos 30 dias (EPSS): 0.52%, maior que 44.4% das vulnerabilidades.
- Correção: atualize para 1.1.0 ou posterior.
Description
Impact
basic-auth-connect <1.1.0 uses a timing-unsafe equality comparison that can leak timing information
Patches
this issue has been fixed in basic-auth-connect 1.1.0
References
NVD description
basic-auth-connect is Connect's Basic Auth middleware in its own module. basic-auth-connect < 1.1.0 uses a timing-unsafe equality comparison that can leak timing information. This issue has been fixed in basic-auth-connect 1.1.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free