Em resumo
- CVE-2024-47889 é uma vulnerabilidade MÉDIO (CVSS 6.6) que afeta actionmailer.
- Chance de exploração nos próximos 30 dias (EPSS): 0.94%, maior que 60.9% das vulnerabilidades.
- Correção: atualize para 6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| actionmailer RubyGems | ≥ 3.0.0, < 6.1.7.9≥ 7.0.0, < 7.0.8.5≥ 7.1.0, < 7.1.4.1≥ 7.2.0, < 7.2.1.1
| 6.1.7.97.0.8.57.1.4.17.2.1.1
|
Description
There is a possible ReDoS vulnerability in the block_format helper in Action Mailer. This vulnerability has been assigned the CVE identifier CVE-2024-47889.
Impact
Carefully crafted text can cause the block_format helper to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade or apply the relevant patch immediately.
Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 requires Ruby 3.2 or greater so is unaffected.
Releases
The fixed releases are available at the normal locations.
Workarounds
Users can avoid calling the block_format helper or upgrade to Ruby 3.2
Credits
Thanks to yuki_osaki for the report!
NVD description
Action Mailer is a framework for designing email service layers. Starting in version 3.0.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in the block_format helper in Action Mailer. Carefully crafted text can cause the block_format helper to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. As a workaround, users can avoid calling the `block_format` helper or upgrade to Ruby 3.2. Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 requires Ruby 3.2 or greater so is unaffected.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free