Em resumo
- CVE-2024-52316 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta org.apache.tomcat:tomcat-catalina, tomcat (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 6.2%, maior que 93.6% das vulnerabilidades.
- Correção: atualize para 10.1.30, 11.0.1, 9.0.96, 10.1.31 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| org.apache.tomcat:tomcat-catalina Maven | ≥ 10.1.0-M1, < 10.1.30≥ 11.0.0-M1, < 11.0.1< 9.0.96
| 10.1.3011.0.19.0.96
|
| tomcat | = 11.0.0≥ 10.1.0, < 10.1.31≥ 9.0.0, < 9.0.96
| 10.1.319.0.96
|
Description
Unchecked Error Condition vulnerability in Apache Tomcat. If Tomcat is configured to use a custom Jakarta Authentication (formerly JASPIC) ServerAuthContext component which may throw an exception during the authentication process without explicitly setting an HTTP status to indicate failure, the authentication may not fail, allowing the user to bypass the authentication process. There are no known Jakarta Authentication components that behave in this way.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M26, from 10.1.0-M1 through 10.1.30, from 9.0.0-M1 through 9.0.95. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100.
Users are recommended to upgrade to version 11.0.0, 10.1.31 or 9.0.96, which fix the issue.
NVD description
Unchecked Error Condition vulnerability in Apache Tomcat. If Tomcat is configured to use a custom Jakarta Authentication (formerly JASPIC) ServerAuthContext component which may throw an exception during the authentication process without explicitly setting an HTTP status to indicate failure, the authentication may not fail, allowing the user to bypass the authentication process. There are no known Jakarta Authentication components that behave in this way.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M26, from 10.1.0-M1 through 10.1.30, from 9.0.0-M1 through 9.0.95.
The following versions were EOL at the time the CVE was created but are
known to be affected: 8.5.0 though 8.5.100. Other EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.0, 10.1.31 or 9.0.96, which fix the issue.
Mais vulnerabilidades de org.apache.tomcat:tomcat-catalina
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free