Em resumo
- CVE-2024-6345 é uma vulnerabilidade ALTO (CVSS 8.8) que afeta setuptools.
- Chance de exploração nos próximos 30 dias (EPSS): 1.9%, maior que 80.1% das vulnerabilidades.
- Correção: atualize para 70.0.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| setuptools PyPI | < 70.0.0
| 70.0.0
|
Description
A vulnerability in the package_index module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to code injection. If these functions are exposed to user-controlled inputs, such as package URLs, they can execute arbitrary commands on the system. The issue is fixed in version 70.0.
NVD description
A vulnerability in the package_index module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to code injection. If these functions are exposed to user-controlled inputs, such as package URLs, they can execute arbitrary commands on the system. The issue is fixed in version 70.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free