Em resumo
- CVE-2024-6982 é uma vulnerabilidade ALTO (CVSS 8.4) que afeta lollms.
- Chance de exploração nos próximos 30 dias (EPSS): 0.46%, maior que 39.9% das vulnerabilidades.
- Correção: atualize para 11.0.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| lollms PyPI | < 11.0.0
| 11.0.0
|
Description
A remote code execution vulnerability exists in the Calculate function of parisneo/lollms version 9.8. The vulnerability arises from the use of Python's eval() function to evaluate mathematical expressions within a Python sandbox that disables __builtins__ and only allows functions from the math module. This sandbox can be bypassed by loading the os module using the _frozen_importlib.BuiltinImporter class, allowing an attacker to execute arbitrary commands on the server. The issue is fixed in version 9.10.
NVD description
A remote code execution vulnerability exists in the Calculate function of parisneo/lollms version 9.8. The vulnerability arises from the use of Python's `eval()` function to evaluate mathematical expressions within a Python sandbox that disables `__builtins__` and only allows functions from the `math` module. This sandbox can be bypassed by loading the `os` module using the `_frozen_importlib.BuiltinImporter` class, allowing an attacker to execute arbitrary commands on the server. The issue is fixed in version 9.10.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free