Em resumo
- CVE-2025-10279 é uma vulnerabilidade ALTO (CVSS 7.0) que afeta mlflow, mlflow (lfprojects).
- Chance de exploração nos próximos 30 dias (EPSS): 0.24%, maior que 15.2% das vulnerabilidades.
- Correção: atualize para 3.4.0rc0, 3.4.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | < 3.4.0rc0
| 3.4.0rc0
|
| mlflow | < 3.4.0
| 3.4.0
|
Description
In mlflow version 2.20.3, the temporary directory used for creating Python virtual environments is assigned insecure world-writable permissions (0o777). This vulnerability allows an attacker with write access to the /tmp directory to exploit a race condition and overwrite .py files in the virtual environment, leading to arbitrary code execution. The issue is resolved in version 3.4.0.
NVD description
In mlflow version 2.20.3, the temporary directory used for creating Python virtual environments is assigned insecure world-writable permissions (0o777). This vulnerability allows an attacker with write access to the `/tmp` directory to exploit a race condition and overwrite `.py` files in the virtual environment, leading to arbitrary code execution. The issue is resolved in version 3.4.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free