| Package | Affected versions | Patched versions |
|---|---|---|
| github.com/hashicorp/consul | < 1.22.0 | 1.22.0 |
| consul | ≥ 1.19.0, < 1.20.8≥ 1.21.0, < 1.21.6< 1.18.12< 1.22.0 | 1.20.81.21.61.18.121.22.0 |
Consul and Consul Enterprise’s (“Consul”) event endpoint is vulnerable to denial of service (DoS) due to lack of maximum value on the Content Length header. This vulnerability, CVE-2025-11375, is fixed in Consul Community Edition 1.22.0 and Consul Enterprise 1.22.0, 1.21.6, 1.20.8 and 1.18.12.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free