Em resumo
- CVE-2025-22153 é uma vulnerabilidade ALTO (CVSS 7.9) que afeta restrictedpython.
- Chance de exploração nos próximos 30 dias (EPSS): 0.40%, maior que 34.2% das vulnerabilidades.
- Correção: atualize para 8.0 ou posterior.
Description
Impact
Via a type confusion bug in the CPython interpreter when using try/except* RestrictedPython could be bypassed.
We believe this should be fixed upstream in Python itself until that we remove support for try/except* from RestrictedPython.
(It has been fixed for some Python versions.)
Patches
Patched in version 8.0 by removing support for try/except* clauses
Workarounds
There is no workaround.
References
none
NVD description
RestrictedPython is a tool that helps to define a subset of the Python language which allows to provide a program input into a trusted environment. Via a type confusion bug in versions of the CPython interpreter starting in 3.11 and prior to 3.13.2 when using `try/except*`, RestrictedPython starting in version 6.0 and prior to version 8.0 could be bypassed. The issue is patched in version 8.0 of RestrictedPython by removing support for `try/except*` clauses. No known workarounds are available.
Mais vulnerabilidades de restrictedpython
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free