Em resumo
- CVE-2025-30474 é uma vulnerabilidade MÉDIO (CVSS 5.0) que afeta org.apache.commons:commons-vfs2, commons vfs (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 0.89%, maior que 59.4% das vulnerabilidades.
- Correção: atualize para 2.10.0 ou posterior.
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Commons VFS.
The FtpFileObject class can throw an exception when a file is not found, revealing the original URI in its message, which may include a password. The fix is to mask the password in the exception message
This issue affects Apache Commons VFS: before 2.10.0.
Users are recommended to upgrade to version 2.10.0, which fixes the issue.
NVD description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Commons VFS.
The FtpFileObject class can throw an exception when a file is not found, revealing the original URI in its message, which may include a password. The fix is to mask the password in the exception message
This issue affects Apache Commons VFS: before 2.10.0.
Users are recommended to upgrade to version 2.10.0, which fixes the issue.
Mais vulnerabilidades de org.apache.commons:commons-vfs2
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free