Em resumo
- CVE-2025-43863 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta vantage6, vantage6 (vantage6).
- Chance de exploração nos próximos 30 dias (EPSS): 0.47%, maior que 40.3% das vulnerabilidades.
- Correção: atualize para 4.11.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| vantage6 PyPI | < 4.11.0
| 4.11.0
|
| vantage6 | < 4.11.0
| 4.11.0
|
Description
Impact
If attacker gets access to an authenticated session, they can try to brute-force the user password by using the change password functionality: they can call that route infinitely which will return the message that password is wrong until it is correct
Patches
This issue has been patched in version 4.11.0
Workarounds
None
NVD description
vantage6 is an open source framework built to enable, manage and deploy privacy enhancing technologies like Federated Learning and Multi-Party Computation. If attacker gets access to an authenticated session, they can try to brute-force the user password by using the change password functionality: they can call that route infinitely which will return the message that password is wrong until it is correct. This vulnerability is fixed in 4.11.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free