Em resumo
- CVE-2025-46572 é uma vulnerabilidade CRÍTICO (CVSS 9.3) que afeta passport-wsfed-saml2.
- Chance de exploração nos próximos 30 dias (EPSS): 0.42%, maior que 36.7% das vulnerabilidades.
- Correção: atualize para 4.6.4 ou posterior.
Description
Overview
This vulnerability allows an attacker to impersonate any user during SAML authentication by crafting a SAMLResponse. This can be done by using a valid SAML object that was signed by the configured IdP.
Am I Affected?
You are affected by this SAML Signature Wrapping vulnerability if you are using passport-wsfed-saml2 version 4.6.3 or below, specifically under the following conditions:
- The service provider is using
passport-wsfed-saml2,
- A valid SAML document signed by the Identity Provider can be obtained.
Fix
Upgrade to v4.6.4 or greater.
NVD description
passport-wsfed-saml2 provides passport strategy for both WS-fed and SAML2 protocol. A vulnerability present starting in version 3.0.5 up to and including version 4.6.3 allows an attacker to impersonate any user during SAML authentication by crafting a SAMLResponse. This can be done by using a valid SAML object that was signed by the configured IdP. Users are affected specifically when the service provider is using passport-wsfed-saml2 and a valid SAML document signed by the Identity Provider can be obtained. Version 4.6.4 contains a fix for the vulnerability.
Mais vulnerabilidades de passport-wsfed-saml2
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free