Em resumo
- CVE-2025-47279 é uma vulnerabilidade BAIXO (CVSS 3.1) que afeta undici.
- Chance de exploração nos próximos 30 dias (EPSS): 0.34%, maior que 27.3% das vulnerabilidades.
- Correção: atualize para 6.21.2, 7.5.0, 5.29.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| undici npm | ≥ 6.0.0, < 6.21.2≥ 7.0.0, < 7.5.0< 5.29.0
| 6.21.27.5.05.29.0
|
Description
Impact
Applications that use undici to implement a webhook-like system are vulnerable. If the attacker set up a server with an invalid certificate, and they can force the application to call the webhook repeatedly, then they can cause a memory leak.
Patches
This has been patched in https://github.com/nodejs/undici/pull/4088.
Workarounds
If a webhook fails, avoid keep calling it repeatedly.
References
Reported as: https://github.com/nodejs/undici/issues/3895
NVD description
Undici is an HTTP/1.1 client for Node.js. Prior to versions 5.29.0, 6.21.2, and 7.5.0, applications that use undici to implement a webhook-like system are vulnerable. If the attacker set up a server with an invalid certificate, and they can force the application to call the webhook repeatedly, then they can cause a memory leak. This has been patched in versions 5.29.0, 6.21.2, and 7.5.0. As a workaound, avoid calling a webhook repeatedly if the webhook fails.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free