Em resumo
- CVE-2025-48947 é uma vulnerabilidade ALTO (CVSS 7.7) que afeta @auth0/nextjs-auth0.
- Chance de exploração nos próximos 30 dias (EPSS): 0.43%, maior que 37.8% das vulnerabilidades.
- Correção: atualize para 4.6.1 ou posterior.
Description
Overview
In Auth0 Next.js SDK versions 4.0.1 to 4.6.0, __session cookies set by auth0.middleware may be cached by CDNs due to missing Cache-Control headers.
Am I Affected?
You are affected by this vulnerability if you meet the following preconditions:
- Applications using the NextJS-Auth0 SDK, versions between 4.0.1 to 4.6.0,
- Applications using CDN or edge caching that caches responses with the Set-Cookie header.
- If the Cache-Control header is not properly set for sensitive responses.
Fix
Upgrade auth0/nextjs-auth0 to v4.6.1.
NVD description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In Auth0 Next.js SDK versions 4.0.1 through 4.6.0, `__session` cookies set by auth0.middleware may be cached by CDNs due to missing Cache-Control headers. Three preconditions must be met in order for someone to be affected by the vulnerability: Applications using the NextJS-Auth0 SDK, versions between 4.0.1 to 4.6.0, applications using CDN or edge caching that caches responses with the Set-Cookie header, and if the Cache-Control header is not properly set for sensitive responses. Users should upgrade auth0/nextjs-auth0 to v4.6.1 to receive a patch.
Mais vulnerabilidades de @auth0/nextjs-auth0
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free