Em resumo
- CVE-2025-49596 é uma vulnerabilidade CRÍTICO (CVSS 9.4) que afeta @modelcontextprotocol/inspector.
- Chance de exploração nos próximos 30 dias (EPSS): 44.5%, maior que 98.8% das vulnerabilidades.
- Correção: atualize para 0.14.1 ou posterior.
Description
Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.
Credit: Rémy Marot [email protected]
NVD description
The MCP inspector is a developer tool for testing and debugging MCP servers. Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.
Mais vulnerabilidades de @modelcontextprotocol/inspector
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free