Em resumo
- CVE-2025-5175 é uma vulnerabilidade MÉDIO (CVSS 5.5) que afeta pypickle, pypickle (erdogant).
- Chance de exploração nos próximos 30 dias (EPSS): 0.25%, maior que 16.0% das vulnerabilidades.
- Correção: atualize para 2.0.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| pypickle PyPI | < 2.0.0
| 2.0.0
|
| pypickle | < 2.0.0
| 2.0.0
|
Description
A vulnerability was found in erdogant pypickle up to 1.1.5. It has been classified as critical. This affects the function Save of the file pypickle/pypickle.py. The manipulation leads to improper authorization. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is named 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.
NVD description
A vulnerability was found in erdogant pypickle up to 1.1.5. It has been classified as critical. This affects the function Save of the file pypickle/pypickle.py. The manipulation leads to improper authorization. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is named 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free