Em resumo
- CVE-2025-54998 é uma vulnerabilidade MÉDIO (CVSS 5.3) que afeta github.com/openbao/openbao, openbao (openbao).
- Chance de exploração nos próximos 30 dias (EPSS): 0.23%, maior que 14.3% das vulnerabilidades.
- Correção: atualize para 2.3.2, 0.0.0-20250807212521-c52795c1ef74 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| github.com/openbao/openbao Go | ≥ 0.1.0, < 2.3.2≥ 0.1.0< 0.0.0-20250807212521-c52795c1ef74
| 2.3.20.0.0-20250807212521-c52795c1ef74
|
| openbao | < 2.3.2
| 2.3.2
|
Description
Impact
Attackers could bypass the automatic user lockout mechanisms in the OpenBao Userpass or LDAP auth systems. This was caused by different aliasing between pre-flight and full login request user entity alias attributions.
Patches
OpenBao v2.3.2 will patch this issue.
Workarounds
Existing users may apply rate-limiting quotas on the authentication endpoints: https://openbao.org/api-docs/system/rate-limit-quotas/
References
This issue was disclosed to HashiCorp and is the OpenBao equivalent of the following tickets:
NVD description
OpenBao exists to provide a software solution to manage, store, and distribute sensitive data including secrets, certificates, and keys. In versions 0.1.0 through 2.3.1, attackers could bypass the automatic user lockout mechanisms in the OpenBao Userpass or LDAP auth systems. This was caused by different aliasing between pre-flight and full login request user entity alias attributions. This is fixed in version 2.3.2. To work around this issue, existing users may apply rate-limiting quotas on the authentication endpoints:, see https://openbao.org/api-docs/system/rate-limit-quotas/.
Mais vulnerabilidades de github.com/openbao/openbao
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free