Em resumo
- CVE-2025-57735 é uma vulnerabilidade CRÍTICO (CVSS 9.1) que afeta apache-airflow, airflow (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 0.67%, maior que 51.9% das vulnerabilidades.
- Correção: atualize para 3.2.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 3.0.0, < 3.2.0
| 3.2.0
|
| airflow | ≥ 3.0.0, < 3.2.0
| 3.2.0
|
Description
When user logged out, the JWT token the user had authtenticated with was not invalidated, which could lead to reuse of that token in case it was intercepted. In Airflow 3.2 we implemented the mechanism that implements token invalidation at logout. Users who are concerned about the logout scenario and possibility of intercepting the tokens, should upgrade to Airflow 3.2+
Users are recommended to upgrade to version 3.2.0, which fixes this issue.
NVD description
When user logged out, the JWT token the user had authtenticated with was not invalidated, which could lead to reuse of that token in case it was intercepted. In Airflow 3.2 we implemented the mechanism that implements token invalidation at logout. Users who are concerned about the logout scenario and possibility of intercepting the tokens, should upgrade to Airflow 3.2+
Users are recommended to upgrade to version 3.2.0, which fixes this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free