Em resumo
- CVE-2025-59536 é uma vulnerabilidade ALTO (CVSS 8.8) que afeta claude code (anthropic), @anthropic-ai/claude-code.
- Chance de exploração nos próximos 30 dias (EPSS): 24.9%, maior que 97.9% das vulnerabilidades.
- Correção: atualize para 1.0.111 ou posterior.
Description
Due to a bug in the startup trust dialog implementation, Claude Code could be tricked to execute code contained in a project before the user accepted the startup trust dialog. Exploiting this requires a user to start Claude Code in an untrusted directory.
Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version.
Thank you to https://hackerone.com/avivdon for reporting this issue!
NVD description
Claude Code is an agentic coding tool. Versions before 1.0.111 were vulnerable to Code Injection due to a bug in the startup trust dialog implementation. Claude Code could be tricked to execute code contained in a project before the user accepted the startup trust dialog. Exploiting this requires a user to start Claude Code in an untrusted directory. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version. This issue is fixed in version 1.0.111.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free