Em resumo
- CVE-2025-59828 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta claude code (anthropic), @anthropic-ai/claude-code.
- Chance de exploração nos próximos 30 dias (EPSS): 0.36%, maior que 30.1% das vulnerabilidades.
- Correção: atualize para 1.0.39 ou posterior.
Description
When using Claude Code with Yarn installed, Yarn config files can trigger code execution when running yarn --version. This could lead to a bypass of the directory trust dialog in Claude Code, as plugins and yarnPath could be executed prior to the user accepting the risks of working in an untrusted directory. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version.
Thank you to Benjamin Faller, Redguard AG and Michael Hess for reporting this issue!
NVD description
Claude Code is an agentic coding tool. Prior to Claude Code version 1.0.39, when using Claude Code with Yarn versions 2.0+, Yarn plugins are auto-executed when running yarn --version. This could lead to a bypass of the directory trust dialog in Claude Code, as plugins would be executed prior to the user accepting the risks of working in an untrusted directory. Users running Yarn Classic were unaffected by this issue. This issue has been fixed in version 1.0.39. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free