Em resumo
- CVE-2025-61672 é uma vulnerabilidade MÉDIO (CVSS 5.3) que afeta matrix-synapse.
- Chance de exploração nos próximos 30 dias (EPSS): 0.48%, maior que 41.2% das vulnerabilidades.
- Correção: atualize para 1.139.1, 1.138.3 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| matrix-synapse PyPI | ≥ 1.139.0rc2, < 1.139.1< 1.138.3
| 1.139.11.138.3
|
Description
Impact
Lack of validation for device keys in Synapse before 1.138.3 and in Synapse 1.139.0 allow an attacker registered on the victim homeserver to degrade federation functionality, unpredictably breaking outbound federation to other homeservers.
Patches
Patched in Synapse 1.138.3, 1.138.4, 1.139.1, and 1.139.2.
Note that even though 1.138.3 and 1.139.1 fix the vulnerability, they inadvertently introduced an unrelated regression. For this reason, it is recommend to skip these releases and upgrading straight to 1.138.4 and 1.139.2.
Workarounds
The vulnerability can only be exploited by users registered on the victim homeserver.
NVD description
Synapse is an open source Matrix homeserver implementation. Lack of validation for device keys in Synapse before 1.138.3 and in Synapse 1.139.0 allow an attacker registered on the victim homeserver to degrade federation functionality, unpredictably breaking outbound federation to other homeservers. The issue is patched in Synapse 1.138.3, 1.138.4, 1.139.1, and 1.139.2. Note that even though 1.138.3 and 1.139.1 fix the vulnerability, they inadvertently introduced an unrelated regression. For this reason, the maintainers of Synapse recommend skipping these releases and upgrading straight to 1.138.4 and 1.139.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free