Em resumo
- CVE-2025-67505 é uma vulnerabilidade ALTO (CVSS 8.4) que afeta com.okta.sdk:okta-sdk-root, java management sdk (okta).
- Chance de exploração nos próximos 30 dias (EPSS): 0.21%, maior que 10.8% das vulnerabilidades.
- Correção: atualize para 20.0.1 ou posterior.
Description
Description
In the Okta Java SDK, race conditions may arise from concurrent requests using the ApiClient class. This could cause a status code or response header from one request’s response to influence another request’s response.
Affected product and versions
You may be affected if you meet the following preconditions:
- Using the Okta Java SDK between versions 11.0.0 and 20.0.0, and
- Implementing a multithreaded application with the ApiClient class where the response status code is used in access control flows
Resolution
Upgrade Okta/okta-sdk-java to versions 21.0.0 or greater.
NVD description
Okta Java Management SDK facilitates interactions with the Okta management API. In versions 11.0.0 through 20.0.0, race conditions may arise from concurrent requests using the ApiClient class. This could cause a status code or response header from one request’s response to influence another request’s response. This issue is fixed in version 20.0.1.
Mais vulnerabilidades de com.okta.sdk:okta-sdk-root
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free