Em resumo
- CVE-2026-106562 é uma vulnerabilidade MÉDIO (CVSS 4.3) que afeta backstage (linuxfoundation), backstage/plugin-search-backend (linuxfoundation), backstage/plugin-search-backend-module-elasticsearch (linuxfoundation).
- Chance de exploração nos próximos 30 dias (EPSS): 0.20%, maior que 9.5% das vulnerabilidades.
- Correção: atualize para 1.54.1, 2.1.6, 1.8.7 ou posterior.
Description
Impact
An authenticated Backstage user subject to a DENY policy for search document types could receive search results they were not authorized to view. This affects deployments with permission.enabled: true and an Elasticsearch or OpenSearch search backend.
Patches
- Upgrade
@backstage/plugin-search-backend to 2.1.6
- Upgrade
@backstage/plugin-search-backend-module-elasticsearch to 1.8.7
Workarounds
If you are unable to upgrade immediately:
- Temporarily modify permission policies to use
CONDITIONAL decisions with per-result filtering rather than blanket DENY for search document types
- Restrict Elasticsearch/OpenSearch index access at the cluster level so that the search service account can only reach expected Backstage indices, limiting the blast radius if the authorization bypass is triggered.
NVD description
Backstage is an open framework for building developer portals. Prior to 2.1.6 in @backstage/plugin-search-backend and 1.8.7 in @backstage/plugin-search-backend-module-elasticsearch, search engine permission filtering could return documents denied by policy. An authenticated Backstage user subject to a DENY policy for search document types could receive unauthorized results in deployments with permission.enabled set to true and an Elasticsearch or OpenSearch backend. This issue is fixed in @backstage/plugin-search-backend 2.1.6 and @backstage/plugin-search-backend-module-elasticsearch 1.8.7.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free