Em resumo
- CVE-2026-12565 é uma vulnerabilidade MÉDIO (CVSS 5.3) que afeta bbot.
- Chance de exploração nos próximos 30 dias (EPSS): 0.21%, maior que 11.0% das vulnerabilidades.
- Correção: atualize para 2.8.5 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| bbot PyPI | ≥ 2.3.1, < 2.8.5
| 2.8.5
|
Description
The unarchive internal module's archive extraction commands perform no code-level validation on extracted file paths, relying entirely on the behavior of external tools (e.g. GNU tar) which varies by platform. While CVE-2025-10284 addressed git-specific RCE vectors, the underlying archive extraction path traversal was never fixed. On systems with GNU tar < 1.34 (Ubuntu 20.04, Debian Buster, CentOS 7, many Docker base images), a malicious archive can write files outside the intended extraction directory.
NVD description
The unarchive internal module's archive extraction commands perform no code-level validation on extracted file paths, relying entirely on the behavior of external tools (e.g. GNU tar) which varies by platform. While CVE-2025-10284 addressed git-specific RCE vectors, the underlying archive extraction path traversal was never fixed. On systems with GNU tar < 1.34 (Ubuntu 20.04, Debian Buster, CentOS 7, many Docker base images), a malicious archive can write files outside the intended extraction directory.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free