Em resumo
- CVE-2026-23535 é uma vulnerabilidade ALTO (CVSS 8.0) que afeta wlc, wlc (weblate).
- Chance de exploração nos próximos 30 dias (EPSS): 0.39%, maior que 32.8% das vulnerabilidades.
- Correção: atualize para 1.17.2 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| wlc PyPI | < 1.17.2
| 1.17.2
|
| wlc | < 1.17.2
| 1.17.2
|
Description
Impact
Multi-translation download could write to an arbitrary location when instructed by a crafted server.
Patches
Workarounds
Do not use wlc download with untrusted servers.
References
This issue was reported to us by wh1zee via HackerOne.
NVD description
wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.2, the multi-translation download could write to an arbitrary location when instructed by a crafted server. This vulnerability is fixed in 1.17.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free