Em resumo
- CVE-2026-23643 é uma vulnerabilidade MÉDIO (CVSS 5.4) que afeta cakephp/cakephp, cakephp (cakephp).
- Chance de exploração nos próximos 30 dias (EPSS): 0.28%, maior que 20.7% das vulnerabilidades.
- Correção: atualize para 5.2.12, 5.3.1 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| cakephp/cakephp Packagist | ≥ 5.2.10, < 5.2.12≥ 5.3.0, < 5.3.1
| 5.2.125.3.1
|
| cakephp | = 5.3.0≥ 5.2.10, < 5.2.12
| 5.2.12
|
Description
Impact
The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation.
Patches
This issue has been fixed in 5.2.12 and 5.3.1
Workarounds
If you are unable to upgrade, you should avoid using Paginator::limitControl() until you can upgrade.
NVD description
CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.
Mais vulnerabilidades de cakephp/cakephp
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free