Em resumo
- CVE-2026-24013 é uma vulnerabilidade CRÍTICO (CVSS 9.1) que afeta apache-iotdb, iotdb (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 0.64%, maior que 50.5% das vulnerabilidades.
- Correção: atualize para 2.0.8 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| apache-iotdb PyPI | ≥ 1.3.3, < 2.0.8
| 2.0.8
|
| iotdb | ≥ 1.3.3, < 2.0.8
| 2.0.8
|
Description
Authentication Bypass by Spoofing vulnerability in Apache IoTDB.
Certain Thrift RPC query handlers lack strict validation of the sessionId
parameter. An attacker can construct requests with a forged sessionId and,
without performing openSession authentication, receive valid query results.
This allows authentication bypass and unauthorized reading of time-series
data.
This issue affects Apache IoTDB: from 1.3.3 before 2.0.8.
Users are recommended to upgrade to version 2.0.8, which fixes the issue.
NVD description
Authentication Bypass by Spoofing vulnerability in Apache IoTDB.
Certain Thrift RPC query handlers lack strict validation of the sessionId
parameter. An attacker can construct requests with a forged sessionId and,
without performing openSession authentication, receive valid query results.
This allows authentication bypass and unauthorized reading of time-series
data.
This issue affects Apache IoTDB: from 1.3.3 before 2.0.8.
Users are recommended to upgrade to version 2.0.8, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free