Em resumo
- CVE-2026-26216 é uma vulnerabilidade CRÍTICO (CVSS 10.0) que afeta crawl4ai, crawl4ai (kidocode).
- Chance de exploração nos próximos 30 dias (EPSS): 6.4%, maior que 93.7% das vulnerabilidades.
- Correção: atualize para 0.8.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| crawl4ai PyPI | < 0.8.0
| 0.8.0
|
| crawl4ai | < 0.8.0
| 0.8.0
|
Description
A critical remote code execution vulnerability exists in the Crawl4AI Docker API deployment. The /crawl endpoint accepts a hooks parameter containing Python code that is executed using exec(). The __import__ builtin was included in the allowed builtins, allowing attackers to import arbitrary modules and execute system commands.
Attack Vector:
POST /crawl
{
"urls": ["https://example.com"],
"hooks": {
"code": {
"on_page_context_created": "async def hook(page, context, **kwargs):\n __import__('os').system('malicious_command')\n return page"
}
}
}
Impact
An unauthenticated attacker can:
- Execute arbitrary system commands
- Read/write files on the server
- Exfiltrate sensitive data (environment variables, API keys)
- Pivot to internal network services
- Completely compromise the server
Mitigation
- Upgrade to v0.8.0 (recommended)
- If unable to upgrade immediately:
- Disable the Docker API
- Block
/crawl endpoint at network level
- Add authentication to the API
Fix Details
- Removed
__import__ from allowed_builtins in hook_manager.py
- Hooks disabled by default (
CRAWL4AI_HOOKS_ENABLED=false)
- Users must explicitly opt-in to enable hooks
Credits
Discovered by Neo by ProjectDiscovery (https://projectdiscovery.io)
NVD description
Crawl4AI versions prior to 0.8.0 contain a remote code execution vulnerability in the Docker API deployment. The /crawl endpoint accepts a hooks parameter containing Python code that is executed using exec(). The __import__ builtin was included in the allowed builtins, allowing unauthenticated remote attackers to import arbitrary modules and execute system commands. Successful exploitation allows full server compromise, including arbitrary command execution, file read and write access, sensitive data exfiltration, and lateral movement within internal networks.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free