Em resumo
- CVE-2026-27497 é uma vulnerabilidade ALTO (CVSS 8.8) que afeta n8n (n8n), n8n.
- Chance de exploração nos próximos 30 dias (EPSS): 0.88%, maior que 59.1% das vulnerabilidades.
- Correção: atualize para 2.9.3, 2.10.1, 1.123.22 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| n8n | ≥ 2.0.0, < 2.9.3≥ 2.10.0, < 2.10.1< 1.123.22
| 2.9.32.10.11.123.22
|
| n8n npm | ≥ 2.0.0, < 2.9.3≥ 2.10.0, < 2.10.1< 1.123.22
| 2.9.32.10.11.123.22
|
Description
Impact
An authenticated user with permission to create or modify workflows could leverage the Merge node's SQL query mode to execute arbitrary code and write arbitrary files on the n8n server.
Patches
The issues have been fixed in n8n versions 2.10.1, 2.9.3, and 1.123.22. Users should upgrade to one of these versions or later to remediate all known vulnerabilities.
Workarounds
If upgrading is not immediately possible, administrators should consider the following temporary mitigations:
- Limit workflow creation and editing permissions to fully trusted users only.
- Disable the Merge node by adding
n8n-nodes-base.merge to the NODES_EXCLUDE environment variable.
These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
NVD description
n8n is an open source workflow automation platform. Prior to versions 2.10.1, 2.9.3, and 1.123.22, an authenticated user with permission to create or modify workflows could leverage the Merge node's SQL query mode to execute arbitrary code and write arbitrary files on the n8n server. The issues have been fixed in n8n versions 2.10.1, 2.9.3, and 1.123.22. Users should upgrade to one of these versions or later to remediate all known vulnerabilities. If upgrading is not immediately possible, administrators should consider the following temporary mitigations. Limit workflow creation and editing permissions to fully trusted users only, and/or disable the Merge node by adding `n8n-nodes-base.merge` to the `NODES_EXCLUDE` environment variable. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free