Em resumo
- CVE-2026-27888 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta pypdf, pypdf (pypdf project).
- Chance de exploração nos próximos 30 dias (EPSS): 0.40%, maior que 34.1% das vulnerabilidades.
- Correção: atualize para 6.7.3 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.7.3
| 6.7.3
|
| pypdf | < 6.7.3
| 6.7.3
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to the RAM being exhausted. This requires accessing the xfa property of a reader or writer and the corresponding stream being compressed using /FlateDecode.
Patches
This has been fixed in pypdf==6.7.3.
Workarounds
If projects cannot upgrade yet, consider applying the changes from PR #3658.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.7.3, an attacker who uses this vulnerability can craft a PDF which leads to the RAM being exhausted. This requires accessing the `xfa` property of a reader or writer and the corresponding stream being compressed using `/FlateDecode`. This has been fixed in pypdf 6.7.3. As a workaround, apply the patch manually.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free