Em resumo
- CVE-2026-27971 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta qwik (qwik), @builder.io/qwik.
- Chance de exploração nos próximos 30 dias (EPSS): 5.5%, maior que 92.8% das vulnerabilidades.
- Correção: atualize para 1.19.1 ou posterior.
Description
Summary
qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime.
Impact
NVD description
Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free