Em resumo
- CVE-2026-28804 é uma vulnerabilidade MÉDIO (CVSS 5.3) que afeta pypdf, pypdf (py-pdf).
- Chance de exploração nos próximos 30 dias (EPSS): 0.44%, maior que 38.6% das vulnerabilidades.
- Correção: atualize para 6.7.5 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.7.5
| 6.7.5
|
| pypdf | < 6.7.5
| 6.7.5
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires accessing a stream which uses the /ASCIIHexDecode filter.
Patches
This has been fixed in pypdf==6.7.5.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3666.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to version 6.7.5, an attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires accessing a stream which uses the /ASCIIHexDecode filter. This issue has been patched in version 6.7.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free