Em resumo
- CVE-2026-31871 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta parse-server (parseplatform), parse-server.
- Chance de exploração nos próximos 30 dias (EPSS): 0.43%, maior que 37.8% das vulnerabilidades.
- Correção: atualize para 9.6.0, 8.6.31, 9.6.0-alpha.5 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.6.0≥ 9.0.0, < 9.6.0< 8.6.31
| 9.6.08.6.31
|
| parse-server npm | ≥ 9.0.0-alpha.1, < 9.6.0-alpha.5< 8.6.31
| 9.6.0-alpha.58.6.31
|
Description
Impact
A SQL injection vulnerability exists in the PostgreSQL storage adapter when processing Increment operations on nested object fields using dot notation (e.g., stats.counter). The sub-key name is interpolated directly into SQL string literals without escaping. An attacker who can send write requests to the Parse Server REST API can inject arbitrary SQL via a crafted sub-key name containing single quotes, potentially executing commands or reading data from the database, bypassing CLPs and ACLs.
Only Postgres deployments are affected.
Patches
The fix escapes single quotes in the sub-key name before interpolating it into the SQL query, preventing breakout from SQL string literals.
Workarounds
There is no known workaround.
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.5 and 8.6.31, a SQL injection vulnerability exists in the PostgreSQL storage adapter when processing Increment operations on nested object fields using dot notation (e.g., stats.counter). The sub-key name is interpolated directly into SQL string literals without escaping. An attacker who can send write requests to the Parse Server REST API can inject arbitrary SQL via a crafted sub-key name containing single quotes, potentially executing commands or reading data from the database, bypassing CLPs and ACLs. Only Postgres deployments are affected. This vulnerability is fixed in 9.6.0-alpha.5 and 8.6.31.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free