Em resumo
- CVE-2026-34236 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta auth0/auth0-php, auth0-php (auth0).
- Chance de exploração nos próximos 30 dias (EPSS): 0.22%, maior que 13.2% das vulnerabilidades.
- Correção: atualize para 8.19.0 ou posterior.
Description
Impact
In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.
Am I Affected?
Consumers are affected if their application meets the following preconditions:
- Their application is using the Auth0-PHP SDK, versions between 8.0.0 and 8.18.0
- Their application is using the Auth0-PHP SDK, or the following SDKs that rely on the Auth0-PHP SDK:
- Auth0/symfony,
- Auth0/laravel0-auth0, or
- Auth0/wordpress
Resolution
Upgrade Auth0/Auth0-PHP to version 8.19.0 or greater.
NVD description
Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. From version 8.0.0 to before version 8.19.0, in applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. This issue has been patched in version 8.19.0.
Mais vulnerabilidades de auth0/auth0-php
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free