Em resumo
- CVE-2026-35052 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta dtale, d-tale (man).
- Chance de exploração nos próximos 30 dias (EPSS): 0.62%, maior que 49.8% das vulnerabilidades.
- Correção: atualize para 3.22.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| dtale PyPI | < 3.22.0
| 3.22.0
|
| d-tale | < 3.22.0
| 3.22.0
|
Description
Impact
Users hosting D-Tale publicly while using a redis or shelf storage layer could be vulnerable to remote code execution allowing attackers to run malicious code on the server.
Patches
Users should upgrade to version 3.22.0.
Workarounds
There are no workarounds for versions < 3.22.0
NVD description
D-Tale is the combination of a Flask back-end and a React front-end to view & analyze Pandas data structures. Prior to 3.22.0, users hosting D-Tale publicly while using a redis or shelf storage layer could be vulnerable to remote code execution allowing attackers to run malicious code on the server. This vulnerability is fixed in 3.22.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free