Em resumo
- CVE-2026-3520 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta multer (expressjs), multer.
- Chance de exploração nos próximos 30 dias (EPSS): 0.82%, maior que 57.2% das vulnerabilidades.
- Correção: atualize para 2.1.1 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| multer | < 2.1.1
| 2.1.1
|
| multer npm | < 2.1.1
| 2.1.1
|
Description
Impact
A vulnerability in Multer versions < 2.1.1 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing stack overflow.
Patches
Users should upgrade to 2.1.1
Workarounds
None
Resources
NVD description
Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.1 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing stack overflow. Users should upgrade to version 2.1.1 to receive a patch. No known workarounds are available.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free