| Package | Affected versions | Patched versions |
|---|---|---|
| github.com/hashicorp/vault | ≥ 0.10.0, ≤ 1.21.4≥ 0.10.0 | |
| vault | ≥ 0.10.0, < 1.19.16≥ 0.10.0, < 2.0.0≥ 1.20.0, < 1.20.10≥ 1.21.0, < 1.21.5 | 1.19.162.0.01.20.101.21.5 |
An authenticated user with access to a kvv2 path through a policy containing a glob may be able to delete secrets they were not authorized to read or write, resulting in denial-of-service. This vulnerability did not allow a malicious user to delete secrets across namespaces, nor read any secret data. Fixed in Vault Community Edition 2.0.0 and Vault Enterprise 2.0.0, 1.21.5, 1.20.10, and 1.19.16.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free