Em resumo
- CVE-2026-3960 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta ai.h2o:h2o-core, h2o, h2o (h2o).
- Chance de exploração nos próximos 30 dias (EPSS): 0.94%, maior que 60.9% das vulnerabilidades.
- Correção: atualize para 3.46.0.10 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| ai.h2o:h2o-core Maven | < 3.46.0.10
| 3.46.0.10
|
| h2o PyPI | < 3.46.0.10
| 3.46.0.10
|
| h2o | < 3.46.0.10
| 3.46.0.10
|
Description
A critical remote code execution vulnerability exists in the unauthenticated REST API endpoint /99/ImportSQLTable in H2O-3 version 3.46.0.9 and prior. The vulnerability arises due to insufficient security controls in the parameter blacklist mechanism, which only targets MySQL JDBC driver-specific dangerous parameters. An attacker can bypass these controls by switching the JDBC URL protocol to jdbc:postgresql: and exploiting PostgreSQL JDBC driver-specific parameters such as socketFactory and socketFactoryArg. This allows unauthenticated attackers to execute arbitrary code on the H2O-3 server with the privileges of the H2O-3 process. The issue is resolved in version 3.46.0.10.
NVD description
A critical remote code execution vulnerability exists in the unauthenticated REST API endpoint /99/ImportSQLTable in H2O-3 version 3.46.0.9 and prior. The vulnerability arises due to insufficient security controls in the parameter blacklist mechanism, which only targets MySQL JDBC driver-specific dangerous parameters. An attacker can bypass these controls by switching the JDBC URL protocol to jdbc:postgresql: and exploiting PostgreSQL JDBC driver-specific parameters such as socketFactory and socketFactoryArg. This allows unauthenticated attackers to execute arbitrary code on the H2O-3 server with the privileges of the H2O-3 process. The issue is resolved in version 3.46.0.10.
Mais vulnerabilidades de ai.h2o:h2o-core
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free