Em resumo
- CVE-2026-40074 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta kit (svelte), @sveltejs/kit.
- Chance de exploração nos próximos 30 dias (EPSS): 0.37%, maior que 30.4% das vulnerabilidades.
- Correção: atualize para 2.57.1 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| kit | < 2.57.1
| 2.57.1
|
| @sveltejs/kit npm | < 2.57.1
| 2.57.1
|
Description
redirect, when called from inside the handle server hook with a location parameter containing characters that are invalid in a HTTP header, will cause an unhandled TypeError. This could result in DoS on some platforms, especially if the location passed to redirect contains unsanitized user input.
NVD description
SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Prior to 2.57.1, redirect, when called from inside the handle server hook with a location parameter containing characters that are invalid in a HTTP header, will cause an unhandled TypeError. This could result in DoS on some platforms, especially if the location passed to redirect contains unsanitized user input. This vulnerability is fixed in 2.57.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free