Em resumo
- CVE-2026-40091 é uma vulnerabilidade MÉDIO (CVSS 4.4) que afeta github.com/authzed/spicedb, spicedb (authzed).
- Chance de exploração nos próximos 30 dias (EPSS): 0.17%, maior que 5.9% das vulnerabilidades.
- Correção: atualize para 1.51.1 ou posterior.
Description
Impact
When SpiceDB starts with log level info, the startup "configuration" log will include the full datastore DSN, including the plaintext password, inside DatastoreConfig.URI.
Patches
v1.51.1
Workarounds
Change the log level to warn or error.
NVD description
SpiceDB is an open source database system for creating and managing security-critical application permissions. In versions 1.49.0 through 1.51.0, when SpiceDB starts with log level info, the startup "configuration" log will include the full datastore DSN, including the plaintext password, inside DatastoreConfig.URI. This issue has been fixed in version 1.51.1. If users are unable to immediately upgrade, they can work around this issue by changing the log level to warn or error.
Mais vulnerabilidades de github.com/authzed/spicedb
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free