Em resumo
- CVE-2026-42570 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta devalue (svelte), devalue.
- Chance de exploração nos próximos 30 dias (EPSS): 0.40%, maior que 33.9% das vulnerabilidades.
- Correção: atualize para 5.8.1 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| devalue | ≥ 5.6.3, < 5.8.1
| 5.8.1
|
| devalue npm | ≥ 5.6.3, < 5.8.1
| 5.8.1
|
Description
devalue.parse could, due to quirks in some JavaScript engines, be convinced to allocate much more memory than was needed when deserializing sparse arrays, leading to excessive memory consumption.
NVD description
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From version 5.6.3 to before version 5.8.1, devalue.parse could, due to quirks in some JavaScript engines, be convinced to allocate much more memory than was needed when deserializing sparse arrays, leading to excessive memory consumption. This issue has been patched in version 5.8.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free