Em resumo
- CVE-2026-45106 é uma vulnerabilidade MÉDIO (CVSS 4.6) que afeta weblate.
- Chance de exploração nos próximos 30 dias (EPSS): 0.21%, maior que 10.9% das vulnerabilidades.
- Correção: atualize para 2026.5 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| weblate PyPI | < 2026.5
| 2026.5
|
Description
Impact
Weblate's live search preview renders unit source and context as HTML without escaping. Any contributor whose content reaches those fields stores HTML and CSS that runs inside the authenticated editor of every user who runs a matching search.
Patches
Workarounds
Only the search preview on the selected views is affected.
Resources
Weblate thanks @adrgs for reporting this issue responsibly via GitHub.
NVD description
Weblate is a web based localization tool. Prior to version 2026.5, Weblate's live search preview renders unit source and context as HTML without escaping. Any contributor whose content reaches those fields stores HTML and CSS that runs inside the authenticated editor of every user who runs a matching search. This issue has been patched in version 2026.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free