Em resumo
- CVE-2026-45149 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta brace-expansion (juliangruber), brace-expansion.
- Chance de exploração nos próximos 30 dias (EPSS): 0.30%, maior que 22.9% das vulnerabilidades.
- Correção: atualize para 5.0.6 ou posterior.
Description
The max option was being applied too late:
When expanding a single large numeric range like {1..10000000}, the sequence generation loop generates all 10 million intermediate elements before the max limit is applied With max=10, the output is correctly limited to 10 items, but the process still allocates ~505 MB and spends ~800ms building the full intermediate array.
Workaround
Ensure the string to be expanded doesn't contain more values than the desired max item count.
NVD description
The brace-expansion library generates arbitrary strings containing a common prefix and suffix. From 5.0.0 to before 5.0.6, the max option was being applied too late. When expanding a single large numeric range like {1..10000000}, the sequence generation loop generates all 10 million intermediate elements before the max limit is applied With max=10, the output is correctly limited to 10 items, but the process still allocates ~505 MB and spends ~800ms building the full intermediate array. This vulnerability is fixed in 5.0.6.
Mais vulnerabilidades de brace-expansion
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free