Em resumo
- CVE-2026-45787 é uma vulnerabilidade CRÍTICO (CVSS 9.1) que afeta electerm (electerm project), electerm.
- Chance de exploração nos próximos 30 dias (EPSS): 0.10%, maior que 1.1% das vulnerabilidades.
- Correção: atualize para 3.9.5 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| electerm | < 3.9.5
| 3.9.5
|
| electerm npm | < 3.9.5
| 3.9.5
|
Description
Impact
Insecure sync encryption: deterministic AES-192-CBC with a fixed zero IV, constant KDF salt, and no MAC leads to confidentiality and integrity failures for synced bookmark/profile data. Attackers can crack common passwords across installs and perform undetected ciphertext bit-flips to alter config/bookmarks.
Patches
Workarounds
References
NVD description
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to 3.9.5, deterministic AES-192-CBC with a fixed zero IV, constant KDF salt, and no MAC leads to confidentiality and integrity failures for synced bookmark/profile data. Attackers can crack common passwords across installs and perform undetected ciphertext bit-flips to alter config/bookmarks. This vulnerability is fixed in 3.9.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free