Em resumo
- CVE-2026-47764 é uma vulnerabilidade ALTO (CVSS 8.4) que afeta pdm.
- Chance de exploração nos próximos 30 dias (EPSS): 0.20%, maior que 9.4% das vulnerabilidades.
- Correção: atualize para 2.27.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| pdm PyPI | < 2.27.0
| 2.27.0
|
Description
InstallDestination.write_to_fs() in src/pdm/installers/installers.py overrides the base class to add symlink/hardlink support but replaces the safe _path_with_destdir() (which validates via Path.resolve() + is_relative_to()) with a bare os.path.join() that performs no path validation. A malicious wheel with traversal entries can write arbitrary files. Same class as Poetry CVE-2026-34591. Fix ready at: https://github.com/pdm-project/pdm/pull/3787.
NVD description
pdm is a Python package and dependency manager supporting the latest PEP standards. Versions prior to 2.27.0 are vulnerable to path traversal through write_to_fs. InstallDestination.write_to_fs() in src/pdm/installers/installers.py overrides the base class to add symlink/hardlink support but replaces the safe _path_with_destdir() (which validates via Path.resolve() + is_relative_to()) with a bare os.path.join() that performs no path validation. A malicious wheel with traversal entries can write arbitrary files. This issue has been fixed in version 2.27.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free