Em resumo
- CVE-2026-48207 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta pyfory, fory (apache).
- Chance de exploração nos próximos 30 dias (EPSS): 0.57%, maior que 47.4% das vulnerabilidades.
- Correção: atualize para 1.0.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| pyfory PyPI | ≥ 0.13.0, < 1.0.0
| 1.0.0
|
| fory | ≥ 0.13.0, < 1.0.0
| 1.0.0
|
Description
Fory PyFory's ReduceSerializer could bypass documented DeserializationPolicy validation hooks during reduce-state restoration and global-name resolution. An application is vulnerable if it deserializes attacker-controlled data using PyFory Python-native mode with strict mode disabled and relies on DeserializationPolicy to restrict unsafe classes, functions, or module attributes.
This issue affects Apache Fory: from before 1.0.0.
Mitigation: Users of Apache Fory are recommended to upgrade to version 1.0.0 or later, which enforces DeserializationPolicy validation for the affected ReduceSerializer paths and thus fixes this issue.
NVD description
Deserialization of untrusted data in Apache Fory PyFory. PyFory's ReduceSerializer could bypass documented DeserializationPolicy validation hooks during reduce-state restoration and global-name resolution. An application is vulnerable if it deserializes attacker-controlled data using PyFory Python-native mode with strict mode disabled and relies on DeserializationPolicy to restrict unsafe classes, functions, or module attributes.
This issue affects Apache Fory: from before 1.0.0.
Mitigation: Users of Apache Fory are recommended to upgrade to version 1.0.0 or later, which enforces DeserializationPolicy validation for the affected ReduceSerializer paths and thus fixes this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free