Em resumo
- CVE-2026-49461 é uma vulnerabilidade MÉDIO (CVSS 5.5) que afeta pypdf, pypdf (py-pdf).
- Chance de exploração nos próximos 30 dias (EPSS): 0.17%, maior que 6.9% das vulnerabilidades.
- Correção: atualize para 6.12.2 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.12.2
| 6.12.2
|
| pypdf | < 6.12.2
| 6.12.2
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires extracting the text of a page which contains a form XObject with self-references.
Patches
This has been fixed in pypdf==6.12.2.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3805.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.12.2, an attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires extracting the text of a page which contains a form XObject with self-references. This vulnerability is fixed in 6.12.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free