Em resumo
- CVE-2026-56817 é uma vulnerabilidade CRÍTICO (CVSS 9.8) que afeta io.netty:netty-codec-xml, netty (netty).
- Chance de exploração nos próximos 30 dias (EPSS): 0.69%, maior que 53.0% das vulnerabilidades.
- Correção: atualize para 4.1.136.Final, 4.2.16.Final, 4.1.136, 4.2.16 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| io.netty:netty-codec-xml Maven | ≥ 4.1.0.Final, < 4.1.136.Final≥ 4.2.0.Final, < 4.2.16.Final
| 4.1.136.Final4.2.16.Final
|
| netty | ≥ 4.1.0, < 4.1.136≥ 4.2.0, < 4.2.16
| 4.1.1364.2.16
|
Description
Any caller that can deliver bytes to a Netty channel pipeline containing XmlDecoder can send XML with a DOCTYPE declaration to a parser instantiated with no security configuration — but whether external entities are actually resolved depends on Aalto XML's async parser behavior, making this a confirmed misconfiguration with conditional exploitability.
NVD description
Netty is a network application framework for development of protocol servers and clients. In versions 4.2.0.Final through 4.2.15.Final and 4.1.0.Final through 4.1.135.Final, any caller that can deliver bytes to a Netty channel pipeline containing `XmlDecoder` can send XML with a `DOCTYPE` declaration to an `AsyncXMLInputFactory` instantiated with no security configuration, leaving DTD and entity handling active depending on Aalto XML async parser behavior and creating conditional XML external entity risk. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.
Mais vulnerabilidades de io.netty:netty-codec-xml
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free