Em resumo
- CVE-2026-57204 é uma vulnerabilidade MÉDIO (CVSS 6.5) que afeta pypdf, pypdf (pypdf project).
- Chance de exploração nos próximos 30 dias (EPSS): 0.37%, maior que 30.6% das vulnerabilidades.
- Correção: atualize para 6.13.3 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.13.3
| 6.13.3
|
| pypdf | < 6.13.3
| 6.13.3
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to large memory usage, as MAX_DECLARED_STREAM_LENGTH is sometimes ignored. This requires parsing a content stream without a /Length value.
Patches
This has been fixed in pypdf==6.13.3.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3871.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.13.3, a maliciously crafted PDF can cause DoS. An attacker who uses this vulnerability can craft a PDF which leads to large memory usage, as MAX_DECLARED_STREAM_LENGTH is sometimes ignored. This requires parsing a content stream without a /Length value. This issue has been fixed in version 6.13.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free