Em resumo
- CVE-2026-59937 é uma vulnerabilidade ALTO (CVSS 7.5) que afeta pypdf, pypdf (pypdf project).
- Chance de exploração nos próximos 30 dias (EPSS): 0.62%, maior que 49.7% das vulnerabilidades.
- Correção: atualize para 6.14.0 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.14.0
| 6.14.0
|
| pypdf | < 6.14.0
| 6.14.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires cross-reference streams with repeated malformed cross-reference streams.
Patches
This has been fixed in pypdf==6.14.0.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3887.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.14.0, an attacker can craft a PDF with repeated malformed cross-reference streams that cause pypdf to spend long runtimes recovering broken cross-reference table entries. This issue is fixed in version 6.14.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free