Em resumo
- CVE-2026-81715 é uma vulnerabilidade BAIXO (CVSS 3.3) que afeta openssl-encrypt, openssl encrypt (jahlives).
- Chance de exploração nos próximos 30 dias (EPSS): 0.26%, maior que 17.9% das vulnerabilidades.
- Correção: atualize para 1.4.9 ou posterior.
Description
openssl_encrypt (pip package openssl-encrypt) versions <= 1.4.8 do not redact the keyserver bearer token passed as the positional argument to 'keyserver set-token' in the --debug argv dump, because sanitize_argv_for_debug fails to sanitize it. As a result the token is printed in cleartext to stderr under --debug (even without --unsafe-show-secrets), persisting the credential in logs and terminal history. Fixed in 1.4.9.
NVD description
openssl_encrypt (pip package openssl-encrypt) versions <= 1.4.8 do not redact the keyserver bearer token passed as the positional argument to 'keyserver set-token' in the --debug argv dump, because sanitize_argv_for_debug fails to sanitize it. As a result the token is printed in cleartext to stderr under --debug (even without --unsafe-show-secrets), persisting the credential in logs and terminal history. Fixed in 1.4.9.
Mais vulnerabilidades de openssl-encrypt
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free